Taxify Service Outage
Incident Report for LOCATE Inventory
Resolved
Taxify has restored service.
Posted 28 days ago. Jun 20, 2019 - 11:24 PDT
Monitoring
We have confirmed that Taxify is currently experiencing an outage. You can track their progress at their status page here: http://status.shipcompliant.com/1901298
Posted 28 days ago. Jun 20, 2019 - 11:13 PDT