Phone System Problems
Incident Report for LOCATE Inventory
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 12:26 PST
Monitoring
Our provider has identified the problem and is monitoring the fix.
Posted Feb 26, 2020 - 09:48 PST
Identified
We are currently experiencing issues with our phone system. We are waiting on our provider to correct this. If you call in we may not be able to answer your call, but will attempt to call you back as soon as possible.
Posted Feb 26, 2020 - 09:01 PST